25 jul 2010

LAB MPLS: BACKUP CON OTRO PE

Escenario:

Un Cliente en nuestra RED MPLS al cual le prestamos el servicio de datos por VPN con UK(ultimo kilómetro) en Fibra Óptica (Metro Ethernet) y le suministramos un backup en Cobre Framrealy desde otro PE de la nube MPLS.

Configurar OSPF en los PE involucrados obtenemos adyacencia con el cliente.

ROUTER CLIENTE
!
interface Loopback100
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
description Datos_PPAL
ip address 192.168.0.2 255.255.255.252
ip ospf cost 50
speed 100
full-duplex
!
!
interface Serial1/0.16 point-to-point
description Datos_BK
ip address 192.168.0.6 255.255.255.252
ip ospf cost 100
frame-relay interface-dlci 16
!
!
router ospf 100
log-adjacency-changes
area 10 stub no-summary
network 192.168.0.0 0.0.0.255 area 10
network 192.168.1.0 0.0.0.255 area 10
!

Neighbor ID Pri State Dead Time Address Interface
192.168.100.22 0 FULL/ - 00:00:34 192.168.0.5 Serial1/0.16
192.168.100.11 1 FULL/DR 00:00:35 192.168.0.1 FastEthernet0/0


ROUTER PE1_BOG

interface FastEthernet1/0.100
description datos
encapsulation dot1Q 100
ip vrf forwarding datos
ip address 192.168.0.1 255.255.255.252
ip ospf cost 50
!
router ospf 100 vrf datos
log-adjacency-changes
area 10 stub no-summary
network 192.168.0.0 0.0.0.3 area 10
!
address-family ipv4 vrf datos
redistribute connected
redistribute ospf 100 vrf datos metric 1 match internal external 1 external 2

Neighbor ID Pri State Dead Time Address Interface
192.168.1.1 1 FULL/BDR 00:00:32 192.168.0.2 FastEthernet1/0.100


ROUTER PE2_BQA

!
interface Serial0/0.216 point-to-point
description datos_bk
ip vrf forwarding datos
ip address 192.168.0.5 255.255.255.252
ip ospf cost 100
frame-relay interface-dlci 216

router ospf 100 vrf datos
log-adjacency-changes
area 10 stub no-summary
network 192.168.0.4 0.0.0.3 area 10

address-family ipv4 vrf datos
redistribute connected
redistribute ospf 100 vrf datos metric 1 match internal external 1 external 2

no synchronization
exit-address-family

Neighbor ID Pri State Dead Time Address Interface
192.168.1.1 0 FULL/ - 00:00:37 192.168.0.6 Serial0/0.216

Con esta informacion nos damos cuenta del primer problema el PE1-BOG y el PE2-BQA no tienen adyacencia.

revisando las tablas de ruteo nos encontramos con otro problema.

PE1-BOG
192.168.0.0/30 is subnetted, 3 subnets
B 192.168.0.8 [200/0] via 192.168.255.233, 01:26:23
C 192.168.0.0 is directly connected, FastEthernet1/0.100
O 192.168.0.4 [110/150] via 192.168.0.2, 00:09:01, FastEthernet1/0.100
192.168.1.0/32 is subnetted, 1 subnets
O 192.168.1.1 [110/51] via 192.168.0.2, 00:09:01, FastEthernet1/0.100
192.168.100.0/32 is subnetted, 2 subnets
B 192.168.100.222 [200/0] via 192.168.255.222, 00:13:47
C 192.168.100.211 is directly connected, Loopback100

PE2-BQA

192.168.0.0/30 is subnetted, 3 subnets
B 192.168.0.8 [200/0] via 192.168.255.233, 01:27:31
O 192.168.0.0 [110/150] via 192.168.0.6, 00:09:56, Serial0/0.216
C 192.168.0.4 is directly connected, Serial0/0.216
192.168.1.0/32 is subnetted, 1 subnets
O 192.168.1.1 [110/101] via 192.168.0.6, 00:09:56, Serial0/0.216
192.168.100.0/32 is subnetted, 2 subnets
C 192.168.100.222 is directly connected, Loopback100
B 192.168.100.211 [200/0] via 192.168.255.211, 00:14:39


Lo rojo nos muestra que ambos PE tienen rutas hacia la lan del CLIENTE por medio de las WAN y lo Naranja que los PE se descubren en OSPF por medio del router del cliente.

De esta forma si un paquete llegara al Cliente desde PE1-BOG este se enviaria directamente al cliente y el cliente responderia enviando el paquete a PE1-BOG, Pero si el paquete pasara por PE2-BQA hacia el cliente el PE2-BQA tambien lo enviaria directo al Cliente, pero este lo devolveria por PE1-BOG.

Que pasa si el PPAL se shutdown , entra el Backup?
Si , pero en los PEs no hubo cambio solo en el cliente que su gateway es ahora el PE2-BAQ , ya que se perdio conectividad por PE1-BOG

Esto nos puede traer inconvenientes en nuestro proceso OSPF pudiendo quedar bloqueado, cuando s realiza el calculo de la red.

Para evitar estos invconvenientes se debe crear un sham-link para crear la adyacenciaentre los dos PE


Para solucionar el problema se trabaja con sham-link
----------------------------------------------------------------
para ello formamos un Link fantasma para unir nuestra area creando adyacencia entre los dos PE


ROUTER PE1_BOG

interface loopback 100
description sham-link
ip vrf forwarding datos
ip address 10.1.1.1 255.255.255.252

router ospf 100 vrf datos
log-adjacency-changes
area 10 sham-link 10.1.1.1 10.2.2.2 cost 10
redistribute bgp 65000 subnets
area 10 stub no-summary
network 192.168.0.0 0.0.0.3 area 10
!

Neighbor ID Pri State Dead Time Address Interface
10.2.2.2 0 FULL/ - - 10.2.2.2 OSPF_SL6
192.168.1.1 1 FULL/DR 00:00:38 192.168.0.2 FastEthernet1/0.100

ROUTER PE2_BQA

!
interface loopback 100
description sham-link
ip vrf forwarding datos
ip address 10.2.2.2 255.255.255.252

router ospf 100 vrf datos
log-adjacency-changes
area 10 sham-link 10.2.2.2 10.1.1.1 cost 10
redistribute bgp 65000 subnets
area 10 stub no-summary
network 192.168.0.4 0.0.0.3 area 10

Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 0 FULL/ - - 10.1.1.1 OSPF_SL4
192.168.1.1 0 FULL/ - 00:00:38 192.168.0.6 Serial0/0.216

No hay comentarios.:

Publicar un comentario